<!DOCTYPE html><html lang="en"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=5.0"><link rel="canonical" href="https://www.paddle.com/learn/metrics"><title>SaaS metrics: what are they, why they're important and how to use them</title><meta name="description" content="Explore core SaaS metrics, retention metrics, payment metrics and more in a collection of resources created for SaaS leaders. Learn which metrics matter most and how to use them."><meta property="og:title" content="SaaS metrics: what are they, why they're important and how to use them"><meta property="twitter:title" content="SaaS metrics: what are they, why they're important and how to use them"><meta name="twitter:card" content="summary_large_image"><meta property="og:image" content="https://images.prismic.io/paddle/eabf6953-5efb-4cf6-9539-3e37572aee14_platform-subscriptions+2.png?auto=compress,format&amp;rect=26,0,1930,950&amp;w=1280&amp;h=630"><meta property="twitter:image" content="https://images.prismic.io/paddle/eabf6953-5efb-4cf6-9539-3e37572aee14_platform-subscriptions+2.png?auto=compress,format&amp;rect=41,0,1900,950&amp;w=1024&amp;h=512"><meta name="next-head-count" content="10"><script defer="" crossorigin="anonymous" nomodule="" src="/_next/static/chunks/polyfills-c67a75d1b6f99dc8.js"></script><script src="/_next/static/chunks/webpack-74bae184a5a151e9.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/chunks/framework-4556c45dd113b893.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/chunks/main-54d468b41e810f8d.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/chunks/pages/_app-c7e565d6ccf287e4.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/chunks/215-3ab8452d9faeea0c.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/chunks/575-40795addcbc13e46.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/chunks/337-5f12d480945ff21c.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/chunks/402-1bb696c06bf1d258.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/chunks/972-0c3583360bee90ee.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/chunks/pages/%5B...uid%5D-ab24246f34311ca0.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/dQUlx6SzDC1-SIPcX8uE0/_buildManifest.js" defer="" crossorigin="anonymous"></script><script src="/_next/static/dQUlx6SzDC1-SIPcX8uE0/_ssgManifest.js" defer="" crossorigin="anonymous"></script><style>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</style><link rel="stylesheet" href="/_next/static/css/c57c117a86194e07.css" crossorigin="anonymous" data-n-g="" media="print" onload="this.media='all'"><noscript><link rel="stylesheet" href="/_next/static/css/c57c117a86194e07.css"></noscript><link rel="stylesheet" href="/_next/static/css/8d2a7ca066c6a8e6.css" crossorigin="anonymous" data-n-p="" media="print" onload="this.media='all'"><noscript><link rel="stylesheet" href="/_next/static/css/8d2a7ca066c6a8e6.css"></noscript><noscript data-n-css=""></noscript></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PTB5MPP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="__next"><div class="toast"><span class="t-badge t-badge--s">Event series</span><span>SaaS Happy Hour 🍻 - Fridays at 16:00 UTC&nbsp;&nbsp;<a href="/events/saas-happy-hour">Register here</a></span></div><header class="c-header" role="navigation"><div class="c-header__inner"><a href="/"><svg xmlns="http://www.w3.org/2000/svg" width="130" height="40" fill="none"><g fill="#FDDD35" clip-path="url(#a)"><path d="M0 20.56v-1.083a5.055 5.055 0 0 0 3.56-1.465 4.983 4.983 0 0 0 1.476-3.535h1.007a4.97 4.97 0 0 0 1.473 3.54 5.04 5.04 0 0 0 3.563 1.468v1.082a5.055 5.055 0 0 0-3.56 1.465 4.983 4.983 0 0 0-1.476 3.535H5.036a4.97 4.97 0 0 0-1.473-3.54A5.066 5.066 0 0 0 0 20.56Zm5.036-7.96h8.66c4.23 0 7.253 3 7.253 7.4 0 4.401-3.021 7.4-7.252 7.4H5.036V40H8.66v-9.4h5.036c6.083 0 10.878-4.76 10.878-10.6 0-5.839-4.795-10.6-10.878-10.6H5.036v3.2ZM37.587 9.36c3.182 0 6.002 1.6 7.774 4.12V10h3.626v20h-3.626v-3.48c-1.817 2.525-4.632 4.12-7.774 4.12-5.964 0-11-4.68-11-10.64 0-5.959 5.037-10.64 11-10.64Zm0 18.08c4.672 0 7.774-3.2 7.774-7.44 0-4.28-3.06-7.44-7.774-7.44-4.19 0-7.374 3-7.374 7.44 0 4.441 3.184 7.44 7.374 7.44ZM62.402 9.36c3.183 0 6.003 1.6 7.775 4.12V0h3.626v30h-3.626v-3.48c-1.772 2.525-4.592 4.12-7.775 4.12-5.962 0-10.998-4.68-10.998-10.64 0-5.959 5.035-10.64 10.998-10.64Zm0 18.08c4.713 0 7.775-3.16 7.775-7.44 0-4.279-3.062-7.44-7.775-7.44-4.19 0-7.373 3-7.373 7.44 0 4.441 3.184 7.44 7.373 7.44ZM87.622 9.36c3.183 0 6.003 1.6 7.776 4.12V0h3.626v30h-3.626v-3.48c-1.773 2.525-4.593 4.12-7.776 4.12-5.962 0-10.998-4.68-10.998-10.64 0-5.959 5.036-10.64 10.998-10.64Zm0 18.08c4.714 0 7.776-3.16 7.776-7.44 0-4.279-3.062-7.44-7.776-7.44-4.19 0-7.372 3-7.372 7.44 0 4.441 3.182 7.44 7.372 7.44ZM102.645 30V0h3.627v30h-3.627ZM119.689 9.4c6.969 0 10.312 5.4 10.312 12.001h-17.402c.563 3.88 3.465 6.4 7.09 6.4 2.498 0 4.431-1.12 5.881-3.32h3.908c-1.37 3.08-4.954 6.12-9.789 6.12-6.083 0-10.797-4.84-10.797-10.6 0-5.758 4.714-10.6 10.797-10.6Zm6.687 9.202c0-3.282-2.82-6.402-6.687-6.402-3.625 0-6.527 2.526-7.09 6.402h13.777Z"></path></g><defs><clipPath id="a"><path fill="#fff" d="M0 0h130v40H0z"></path></clipPath></defs></svg></a><nav class="c-header__nav"><div class="o-dropdown"><button class="o-dropdown__top-level"><a class="o-header-link t-nav-link" data-text="Platform" href="/platform">Platform</a></button><div class="o-dropdown__popover"><div class="o-dropdown__primary"><span class="o-dropdown__heading t-overline">Features</span><a class="o-dropdown__link t-nav-link" href="/platform"><span class="o-dropdown__label"><span>The whole package</span></span><span class="o-dropdown__caption">Explore Paddle's complete payments infrastructure for SaaS</span></a></div><div class="o-dropdown__secondary"><a class="o-dropdown__link t-nav-link" href="/platform/checkout"><span class="o-dropdown__label"><span>Checkout</span></span><span class="o-dropdown__caption">High-performing and secure</span></a><a class="o-dropdown__link t-nav-link" href="/platform/invoicing"><span class="o-dropdown__label"><span>Invoicing</span><span class="t-badge">Early Access</span></span><span class="o-dropdown__caption">Simplified and scalable B2B billing</span></a><a class="o-dropdown__link t-nav-link" href="/platform/subscriptions"><span class="o-dropdown__label"><span>Subscriptions</span></span><span class="o-dropdown__caption">Flexible recurring billing</span></a><a class="o-dropdown__link t-nav-link" href="/platform/payments"><span class="o-dropdown__label"><span>Payments</span></span><span class="o-dropdown__caption">Your all-in-one payments toolkit</span></a><a class="o-dropdown__link t-nav-link" href="/platform/tax-and-compliance"><span class="o-dropdown__label"><span>Tax &amp; compliance</span></span><span class="o-dropdown__caption">Be globally compliant from day one</span></a><a class="o-dropdown__link t-nav-link" href="/platform/fraud-protection"><span class="o-dropdown__label"><span>Fraud protection</span></span><span class="o-dropdown__caption">Offload your fraud concerns</span></a><a class="o-dropdown__link t-nav-link" href="/platform/reporting"><span class="o-dropdown__label"><span>Reporting</span></span><span class="o-dropdown__caption">Get a single source of revenue truth</span></a><a class="o-dropdown__link t-nav-link" href="/platform/upsell-insights"><span class="o-dropdown__label"><span>Upsell insights</span></span><span class="o-dropdown__caption">Grow average customer value</span></a><a class="o-dropdown__link t-nav-link" href="/platform/in-app-purchase"><span class="o-dropdown__label"><span>In-app purchase</span></span><span class="o-dropdown__caption">A flexible, low cost alternative</span></a><a class="o-dropdown__link t-nav-link" href="/platform/profitwell-metrics"><span class="o-dropdown__label"><span>ProfitWell Metrics</span><span class="t-badge">Coming soon</span></span><span class="o-dropdown__caption">Real-time subscription data</span></a></div><div class="o-dropdown__tertiary"><span class="o-dropdown__heading t-overline">Services</span><a class="o-dropdown__link t-nav-link" href="/platform/customer-support"><span><span>Customer support</span></span></a><a class="o-dropdown__link t-nav-link" href="/platform/migration-service"><span><span>Migration service</span></span></a><a class="o-dropdown__link t-nav-link" href="/platform/billing-support"><span><span>Billing support</span></span></a><a class="o-dropdown__link t-nav-link" href="/platform/advisory"><span><span>Advisory</span></span></a><a class="o-dropdown__link t-nav-link" href="/platform/implementation"><span><span>Implementation service</span></span></a></div></div></div><div class="o-dropdown"><button class="o-dropdown__top-level"><a class="o-header-link t-nav-link" data-text="Use cases" href="/use-cases">Use cases</a></button><div class="o-dropdown__popover"><div class="o-dropdown__primary"><a class="o-dropdown__link t-nav-link" href="/use-cases"><span class="o-dropdown__label"><span>See all use cases</span></span><span class="o-dropdown__caption">How Paddle can help you from launch to exit</span></a><a class="o-dropdown__link t-nav-link" href="/use-cases/launch"><span class="o-dropdown__label"><span>Launch your SaaS</span></span><span class="o-dropdown__caption">Be ready to scale from the start</span></a><a class="o-dropdown__link t-nav-link" href="/use-cases/self-serve"><span class="o-dropdown__label"><span>Introduce PLG</span></span><span class="o-dropdown__caption">Open the floodgates to inbound</span></a><a class="o-dropdown__link t-nav-link" href="/use-cases/selling-globally"><span class="o-dropdown__label"><span>Sell SaaS globally</span></span><span class="o-dropdown__caption">Seize your global opportunity</span></a><a class="o-dropdown__link t-nav-link" href="/use-cases/revenue-data"><span class="o-dropdown__label"><span>Reconcile revenue data</span></span><span class="o-dropdown__caption">Unify self-serve and sales-assisted</span></a><a class="o-dropdown__link t-nav-link" href="/use-cases/investment-ready"><span class="o-dropdown__label"><span>Be investment-ready</span></span><span class="o-dropdown__caption">All set for your next big milestone</span></a></div></div></div><a class="single-link_o-single-link__RM98n" href="/pricing"><span class="o-header-link t-nav-link" data-text="Pricing">Pricing</span></a><div class="o-dropdown"><button class="o-dropdown__top-level"><a class="o-header-link t-nav-link" data-text="Resources" href="/resources">Resources</a></button><div class="o-dropdown__popover"><div class="o-dropdown__secondary"><a class="o-dropdown__link t-nav-link" href="/resources"><span class="o-dropdown__label"><span>Resource hub</span></span><span class="o-dropdown__caption">Insights and guides on growing a successful software business</span></a><a class="o-dropdown__link t-nav-link" href="/customers"><span class="o-dropdown__label"><span>Customer stories</span></span><span class="o-dropdown__caption">How software businesses grow faster with Paddle</span></a><a class="o-dropdown__link t-nav-link" href="/blog"><span class="o-dropdown__label"><span>Blog</span></span><span class="o-dropdown__caption">The latest SaaS insights, opinions, and talking points</span></a><a class="o-dropdown__link t-nav-link" href="/explore-paddle"><span class="o-dropdown__label"><span>Explore Paddle</span></span><span class="o-dropdown__caption">Learn more about Paddle's products and services</span></a><a class="o-dropdown__link t-nav-link" href="https://tax-agony.paddle.com"><span class="o-dropdown__label"><span>Tax agony index</span></span><span class="o-dropdown__caption">Discover the most painful tax jurisdictions</span></a></div></div></div><div class="o-dropdown"><button class="o-dropdown__top-level"><a class="o-header-link t-nav-link" data-text="Support" href="/help">Support</a></button><div class="o-dropdown__popover"><div class="o-dropdown__primary"><span class="o-dropdown__heading t-overline">Customer Support</span><a class="o-dropdown__link t-nav-link" href="/help"><span class="o-dropdown__label"><span>Help center</span></span><span class="o-dropdown__caption">Find answers to your questions about Paddle</span></a><a class="o-dropdown__link t-nav-link" href="https://developer.paddle.com"><span class="o-dropdown__label"><span>Developer docs</span></span><span class="o-dropdown__caption">Explore Paddle's APIs, webhooks, reference, and guides</span></a><a class="o-dropdown__link t-nav-link" href="https://paddle.status.io"><span class="o-dropdown__label"><span>Platform status</span></span><span class="o-dropdown__caption">See if everything is running as it should be</span></a></div><div class="o-dropdown__secondary"><span class="o-dropdown__heading t-overline">Buyer Support</span><a class="o-dropdown__link t-nav-link" href="https://paddle.net/?__hstc=246466203.5b65ba52ac421e17b41151d24aaff0e3.1638286906011.1642781783872.1643021057071.58&amp;__hssc=246466203.3.1643021057071&amp;__hsfp=3498780729"><span class="o-dropdown__label"><span>Refunds and cancellations</span></span><span class="o-dropdown__caption">Request a refund or cancel a subscription</span></a><a class="o-dropdown__link t-nav-link" href="https://paddle.net/?__hstc=246466203.5b65ba52ac421e17b41151d24aaff0e3.1638286906011.1642781783872.1643021057071.58&amp;__hssc=246466203.3.1643021057071&amp;__hsfp=3498780729"><span class="o-dropdown__label"><span>Check a charge</span></span><span class="o-dropdown__caption">Find out why Paddle has charged you</span></a></div></div></div></nav><div class="c-header__auth"><a class="o-single-link" href="https://vendors.paddle.com/login"><span class="o-header-link t-nav-link">Login</span></a><a class="o-button o-button--primary" data-gtm-key="button" href="/get-started"><span>Get started</span></a></div></div></header><header class="c-header c-header--mobile" role="navigation"><div class="c-header__inner"><nav class="c-overlay-nav"><div class="c-overlay-nav__section"><span class="c-overlay-nav__heading t-overline"></span><a href="/platform">Platform</a><a href="/platform/services">Services</a></div><div class="c-overlay-nav__section"><span class="c-overlay-nav__heading t-overline">Features</span><a href="/platform/checkout">Checkout</a><a href="/platform/invoicing">Invoicing</a><a href="/platform/subscriptions">Subscriptions</a><a href="/platform/payments">Payments</a><a href="/platform/tax-and-compliance">Tax &amp; compliance</a><a href="/platform/fraud-protection">Fraud protection</a><a href="/platform/reporting">Reporting</a><a href="/platform/upsell-insights">Upsell insights</a><a href="/platform/in-app-purchase">In-app purchase</a><a href="/platform/profitwell-metrics">ProfitWell Metrics</a></div><div class="c-overlay-nav__section"><span class="c-overlay-nav__heading t-overline">Use cases</span><a href="/use-cases/launch">Launch your SaaS</a><a href="/use-cases/self-serve">Introduce PLG</a><a href="/use-cases/selling-globally">Sell SaaS globally</a><a href="/use-cases/revenue-data">Reconcile reporting</a><a href="/use-cases/investment-ready">Be investment ready</a></div><div class="c-overlay-nav__section"><span class="c-overlay-nav__heading t-overline"></span><a href="/pricing">Pricing</a><a href="/resources">Resources</a><a href="/customers">Customer stories</a><a href="/careers">Careers</a><a href="/help">Help center</a><a href="https://developer.paddle.com/">Developer docs</a></div><div class="c-overlay-nav__auth"><a class="o-single-link" href="https://vendors.paddle.com/login"><span class="o-header-link t-nav-link">Login</span></a><a class="o-button o-button--primary" data-gtm-key="button" href="/get-started"><span>Get Started</span></a></div></nav><button class="c-header__mobile-hamburger hamburger hamburger--collapse" type="button" title="Toggle navigation"><span class="hamburger-box"><span class="hamburger-inner"></span></span></button></div></header><main><div class="o-slice c-hero o-slice--bottom-flush o-slice--top-l c-hero--default c-hero--left"><div class="c-hero__content"><h1 class="c-hero__heading t-heading t-heading--xxl t-heading--gradient">SaaS Metrics</h1><p>Explore core SaaS metrics, retention metrics, payment metrics and more in a collection of resources created for SaaS leaders.</p><div class="c-hero__actions"></div></div></div><div class="o-slice o-slice--bottom-l o-slice--top-l"><div class="article-list_c-articles__9B1gy article-list_c-articles--feature-list__gBME0"><div class="article-list_c-articles__header__b9c7x"></div><div class="article-list_c-articles__inner__mazD2"><div class="article-list_c-articles__featured__vls9I"><a class="o-article o-article--l" href="/resources/the-ultimate-saas-metrics-guide"><div class="o-article__meta"></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/ac34c189-3850-40b2-ba82-1561f4a69f2a_styleframe-brand+video+5.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">The ultimate SaaS metrics guide: What to track and why</span></div></div></a></div><div class="article-list_c-articles__list__Zz2H9"><a class="o-article o-article--s" href="/blog/net-revenue-retention-the-new-benchmark-metric-for-saas"><div class="o-article__meta"><div class="t-body--s o-article__date"><span class="date_o-date__wrAy5">Invalid Date</span></div></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/b18e676d-5ca0-4365-bc18-5e583c73c63a_platform-reporting-spreadsheet.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">Net revenue retention: Definition, formula &amp; ways to improve NRR </span></div></div></a><a class="o-article o-article--s" href="/resources/guide-to-monthly-recurring-revenue-mrr"><div class="o-article__meta"></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/88a3d189-d4d5-47cd-8285-2ef55b57eec5_Platform-Subscriptions-main.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">The SaaS guide to monthly recurring revenue (MRR)</span></div></div></a><a class="o-article o-article--s" href="/resources/guide-to-customer-lifetime-value"><div class="o-article__meta"></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/1c21bd34-652d-46da-bb51-91a9ea6c9c58_abstract-filler+1.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">The SaaS guide to customer lifetime value&nbsp;(CLV)</span></div></div></a></div></div></div></div><div class="o-slice o-slice--bottom-flush o-slice--top-l"><div class="c-section-heading__parent"><span class="t-overline">Metrics in practice</span><h1 class="t-heading t-heading--l t-heading--gradient">What to measure and why</h1></div><div class="c-section-heading__child"></div></div><div class="o-slice o-slice--bottom-l o-slice--top-l"><div class="article-list_c-articles__9B1gy article-list_c-articles--grid-list__dsySr"><div class="article-list_c-articles__header__b9c7x"></div><div class="article-list_c-articles__inner__mazD2"><div class="article-list_c-articles__grid__XOjtS"><a class="o-article" href="/blog/saas-metrics-and-financial-models"><div class="o-article__meta"><div class="t-body--s o-article__date"><span class="date_o-date__wrAy5">Invalid Date</span></div></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/eabf6953-5efb-4cf6-9539-3e37572aee14_platform-subscriptions+2.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">SaaS metrics and financial models: What investors are looking for</span></div></div></a><a class="o-article" href="/blog/saas-due-diligence-what-vcs-are-looking-for"><div class="o-article__meta"><div class="t-body--s o-article__date"><span class="date_o-date__wrAy5">Invalid Date</span></div></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/fc2008da-c7af-4e57-9a26-fd227c0a2401_abstract-paddle-hand.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">SaaS due diligence: What VCs are looking for</span></div></div></a></div><div class="article-list_c-articles__list__Zz2H9"><a class="o-article o-article--s" href="/resources/financial-forecasting"><div class="o-article__meta"></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/fedeb6f7-b6df-40da-9795-6998ddc64d22_abstract-filler+5.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">7-step guide to financial forecasting &amp; planning for any business</span></div></div></a><a class="o-article o-article--s" href="/resources/saas-benchmarks"><div class="o-article__meta"></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/8bc06c1a-e0ff-46cb-b2c1-803052925600_styleframe-brand+video+3.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">SaaS benchmarks: What to measure, and how</span></div></div></a></div></div></div></div><div class="o-slice o-slice--bottom-flush o-slice--top-l"><div class="c-section-heading__parent"><span class="t-overline">Churn &amp; retention metrics</span><h1 class="t-heading t-heading--l t-heading--gradient">Keep your customers for longer</h1></div><div class="c-section-heading__child"></div></div><div class="o-slice o-slice--bottom-l o-slice--top-l"><div class="article-list_c-articles__9B1gy article-list_c-articles--grid-3__WJuwf"><div class="article-list_c-articles__header__b9c7x"></div><div class="article-list_c-articles__inner__mazD2"><div class="article-list_c-articles__grid__XOjtS"><a class="o-article" href="/resources/how-to-calculate-and-reduce-churn"><div class="o-article__meta"></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/76d42d24-a2d1-4336-9e4e-44820c3f898b_styleframe-brand+video+26.png?auto=format&amp;rect=0%2C0%2C2036%2C976&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">How to calculate (and reduce) your churn rate</span></div></div></a><a class="o-article" href="/resources/the-saas-guide-to-customer-renewal-rate"><div class="o-article__meta"></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/fc2008da-c7af-4e57-9a26-fd227c0a2401_abstract-paddle-hand.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">The SaaS guide to customer renewal rate</span></div></div></a><a class="o-article" href="/resources/customer-churn-analysis"><div class="o-article__meta"></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/410bcaa1-30e7-4045-a121-ab8f37daba60_abstract-sand-timer-2.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">Customer churn analysis: <br>One of SaaS’ most important processes</span></div></div></a></div></div></div></div><div class="o-slice c-parent-child o-slice--bottom-l o-slice--top-flush c-parent-child--left"><div class="c-parent-child__parent"><h2 class="t-heading t-heading--l t-heading--gradient">10 essential customer retention metrics you should track for success</h2><div><a class="o-button o-button--anchor-link" href="https://www.paddle.com/blog/10-essential-saas-customer-retention-metrics"><span>Read now</span> </a></div></div><div class="c-parent-child__child"><img alt="" src="https://prismic-io.s3.amazonaws.com/paddle/d28c18e3-1679-4ba2-a931-197d6dfe6599_services-seller-support-hero.png?auto=format&amp;fit=crop&amp;ixlib=react-9.5.2"></div></div><div class="o-slice o-slice--bottom-flush o-slice--top-l"><div class="c-section-heading__parent"><span class="t-overline">Payment metrics</span><h1 class="t-heading t-heading--l t-heading--gradient">From conversion to cash</h1></div><div class="c-section-heading__child"></div></div><div class="o-slice o-slice--bottom-l o-slice--top-l"><div class="article-list_c-articles__9B1gy article-list_c-articles--feature-list__gBME0"><div class="article-list_c-articles__header__b9c7x"></div><div class="article-list_c-articles__inner__mazD2"><div class="article-list_c-articles__featured__vls9I"><a class="o-article o-article--l" href="/blog/key-metrics-to-track-for-converting-freemium-to-paid"><div class="o-article__meta"><div class="t-body--s o-article__date"><span class="date_o-date__wrAy5">Invalid Date</span></div></div><div class="o-article__thumbnail"><img alt="dollar coin" src="https://images.prismic.io/paddle/2233542b-1d46-4a04-a87f-d810dc5cdca8_abstract-dollar.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">Key metrics to track for converting freemium to paid</span></div></div></a></div><div class="article-list_c-articles__list__Zz2H9"><a class="o-article o-article--s" href="/blog/payment-acceptance"><div class="o-article__meta"><div class="t-body--s o-article__date"><span class="date_o-date__wrAy5">Invalid Date</span></div></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/34c8f1cf-b5c2-4741-a4f5-f389054cdc10_global-payments.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">Payment acceptance: <br>The million-dollar metric most SaaS executives are missing</span></div></div></a><a class="o-article o-article--s" href="/blog/6-reasons-for-low-payment-acceptance-in-saas"><div class="o-article__meta"><div class="t-body--s o-article__date"><span class="date_o-date__wrAy5">Invalid Date</span></div></div><div class="o-article__thumbnail"><img alt="" src="https://images.prismic.io/paddle/fe7eaf22-7afd-4801-9240-29486afb9f16_digital-messy+laptop.png?auto=format&amp;rect=0%2C0%2C1980%2C949&amp;w=480&amp;h=230&amp;fit=crop&amp;ixlib=react-9.5.2"></div><div class="o-article__detail"><div class="o-article__title"><span class="o-article__heading t-heading t-heading--xs">6 reasons your SaaS payments are failing and what you can do about it </span></div></div></a></div></div></div></div><div class="o-slice c-parent-child o-slice--bottom-xl o-slice--top-l c-parent-child--left"><div class="c-parent-child__parent"><span class="t-overline">Coming soon</span><h2 class="t-heading t-heading--l t-heading--gradient">Paddle + ProfitWell Metrics integration</h2><p>With Paddle + ProfitWell Metrics integration, you get powerful, out-of-the-box features helping you track your subscription growth in real-time.</p><div><a class="o-button o-button--anchor-link" href="https://www.paddle.com/blog/coming-soon-profitwell-metrics-integration"><span>Read more</span> </a></div></div><div class="c-parent-child__child"><img alt="" src="https://images.prismic.io/paddle/af57d3ba-c42b-4730-83bd-fff7e1e25f73_pw-platform.png?auto=format&amp;fit=crop&amp;ixlib=react-9.5.2"></div></div><div class="c-banner o-slice o-slice--bottom-l o-slice--top-xl"><div class="c-banner__inner" data-theme="light"><div><h3>An A-Z of SaaS metrics</h3><p>Do you know your ARPU from your EBIT? There's a SaaS metric for everything these days. Explore a load of them in our SaaS metrics glossary.</p></div><div><div class="c-banner__actions"><a class="o-button o-button--primary" data-gtm-key="button" href="/glossary/saas-metrics"><span>View SaaS metrics glossary</span></a></div><div class="c-banner__disclaimer"></div></div></div></div></main><footer class="c-footer-nav"><div class="c-footer-nav__anim-overlay"><div class="c-footer-nav__anim-grid"><div class="c-footer-nav__anim-fade"></div><div class="c-footer-nav__anim-lines"></div></div></div><div class="c-footer-nav__inner"><div class="c-footer-nav__masthead"><div class="c-footer-nav__social"><a class="o-single-link" href="https://linkedin.com/company/paddle"><span class="o-header-link t-nav-link" data-text="Linkedin">Linkedin</span></a><a class="o-single-link" href="https://twitter.com/PaddleHQ"><span class="o-header-link t-nav-link" data-text="Twitter">Twitter</span></a><a class="o-single-link" href="https://www.instagram.com/paddleteam/"><span class="o-header-link t-nav-link" data-text="Instagram">Instagram</span></a><a class="o-single-link" href="https://www.youtube.com/channel/UCK1qyXbgE-kcGA4LMGdL7PA"><span class="o-header-link t-nav-link" data-text="Youtube">Youtube</span></a><a class="o-single-link" href="https://facebook.com/PaddleHQ"><span class="o-header-link t-nav-link" data-text="Facebook">Facebook</span></a><a class="o-single-link" href="https://www.glassdoor.co.uk/Overview/Working-at-Paddle-EI_IE988509.11,17.htm"><span class="o-header-link t-nav-link" data-text="Glassdoor">Glassdoor</span></a><a href="#" class="iubenda-cs-preferences-link">Update your cookie preferences</a></div></div><nav class="c-footer-nav__nav"><div class="footer-group_c-footer-group__skL1f"><span class="t-overline">Platform</span><a class="t-nav-link" href="/platform">Platform overview</a><a class="t-nav-link" href="/platform/checkout">Checkout</a><a class="t-nav-link" href="/platform/invoicing">Invoicing</a><a class="t-nav-link" href="/platform/subscriptions">Subscriptions</a><a class="t-nav-link" href="/platform/payments">Payments</a><a class="t-nav-link" href="/platform/tax-and-compliance">Tax &amp; compliance</a><a class="t-nav-link" href="/platform/fraud-protection">Fraud protection</a><a class="t-nav-link" href="/platform/reporting">Reporting</a><a class="t-nav-link" href="/platform/upsell-insights">Upsell insights</a><a class="t-nav-link" href="/platform/in-app-purchase">In-app purchase</a><a class="t-nav-link" href="/platform/services">All services</a></div><div class="footer-group_c-footer-group__skL1f"><span class="t-overline">Use cases</span><a class="t-nav-link" href="/use-cases">Use cases overview</a><a class="t-nav-link" href="/use-cases/selling-globally">Sell SaaS globally</a><a class="t-nav-link" href="/use-cases/self-serve">Introduce PLG</a><a class="t-nav-link" href="/use-cases/launch">Launch your SaaS</a><a class="t-nav-link" href="/use-cases/investment-ready">Be investment ready</a><a class="t-nav-link" href="/use-cases/revenue-data">Reconcile revenue data</a><a class="t-nav-link" href="/use-cases/why-merchant-of-record">Why merchant of record</a><a class="t-nav-link" href="/use-cases/merchant-of-record-for-saas">Choose the right MOR for your SaaS</a></div><div class="footer-group_c-footer-group__skL1f"><span class="t-overline">Resources</span><a class="t-nav-link" href="/resources">Resource hub</a><a class="t-nav-link" href="/customers">Customer stories</a><a class="t-nav-link" href="/blog">Blog</a><a class="t-nav-link" href="/explore-paddle">Explore Paddle</a><a class="t-nav-link" href="https://tax-agony.paddle.com/">Sales tax index</a><a class="t-nav-link" href="/glossary/saas-metrics">A-Z of SaaS metrics</a><a class="t-nav-link" href="/learn/selling-saas-globally">Selling SaaS Globally Handbook</a><a class="t-nav-link" href="/revenue-delivery-explained">Revenue delivery explained</a></div><div class="footer-group_c-footer-group__skL1f"><span class="t-overline">Compare</span><a class="t-nav-link" href="/compare">Compare providers</a><a class="t-nav-link" href="/compare/stripe">Compare to Stripe</a><a class="t-nav-link" href="/compare/fastspring">Compare to FastSpring</a><a class="t-nav-link" href="/compare/2checkout">Compare to 2Checkout</a><a class="t-nav-link" href="/compare/digital-river">Compare to Digital River</a><a class="t-nav-link" href="/compare/braintree">Compare to Braintree</a><a class="t-nav-link" href="/compare/chargebee">Compare to Chargebee</a><a class="t-nav-link" href="/compare/taxjar">Compare to Taxjar</a><a class="t-nav-link" href="/compare/avalara">Compare to Avalara</a></div><div class="footer-group_c-footer-group__skL1f"><span class="t-overline">About</span><a class="t-nav-link" href="/about">About us</a><a class="t-nav-link" href="/careers">Careers</a><a class="t-nav-link" href="/press">Press</a><a class="t-nav-link" href="/partner-program">Partner with Paddle</a></div><div class="footer-group_c-footer-group__skL1f"><span class="t-overline">Support</span><a class="t-nav-link" href="https://developer.paddle.com/">Developer docs</a><a class="t-nav-link" href="https://developer.paddle.com/getting-started/3ba0852f4760c-create-a-paddle-sandbox-account">Sandbox</a><a class="t-nav-link" href="/help">Help center</a><a class="t-nav-link" href="/platform/integration">Integration</a><a class="t-nav-link" href="https://paddle.status.io/">Platform status</a><a class="t-nav-link" href="https://paddle.net/?__hstc=246466203.5b65ba52ac421e17b41151d24aaff0e3.1638286906011.1642781783872.1643021057071.58&amp;__hssc=246466203.3.1643021057071&amp;__hsfp=3498780729">Refunds and cancellations</a><a class="t-nav-link" href="https://paddle.net/?__hstc=246466203.5b65ba52ac421e17b41151d24aaff0e3.1638286906011.1642781783872.1643021057071.58&amp;__hssc=246466203.3.1643021057071&amp;__hsfp=3498780729">Check a charge</a><a class="t-nav-link" href="/legal/gdpr">GDPR readiness</a><a class="t-nav-link" href="/legal/soc-2-compliance">SOC 2 compliance</a><a class="t-nav-link" href="/legal/terms">Terms of use</a><a class="t-nav-link" href="/legal/privacy">Privacy policy</a><a class="t-nav-link" href="/vulnerability-disclosure-policy">Vulnerability disclosure policy</a></div></nav></div></footer></div><script id="__NEXT_DATA__" type="application/json" crossorigin="anonymous">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</script><!-- For search console removal -->
<meta name="google-site-verification" content="VATI-IT1fToXpJX4Fm1bjT2orLk_vjZz10JYgAeSXB4" /></body></html>